synit/packaging/packages/synit-pid1/APKBUILD

25 lines
551 B
Plaintext

# Contributor: Tony Garnock-Jones <tonyg@leastfixedpoint.com>
# Maintainer: Tony Garnock-Jones <tonyg@leastfixedpoint.com>
pkgname=synit-pid1
pkgver=$(cat VERSION)$(cat GITVERSION)
pkgrel=0
pkgdesc="synit pid 1 program"
url="https://synit.org/"
arch="all"
license="GPLv3"
depends="syndicate-server s6"
makedepends=""
source=""
builddir="$srcdir/"
options="!check"
build() {
:
}
package() {
mkdir -p "$pkgdir/sbin"
cp -p "$startdir/synit-pid1.${CARCH}" "$pkgdir/sbin/synit-pid1"
cp -p "$startdir/synit-log" "$pkgdir/sbin/synit-log"
}